Шаг 81 - Изучаем форму - ПриВыбореЗакладки

Оказывается, есть функция, которая используется при выборе закладки. Вот в ней-то и надо переключать слои и ставить их в соответствие закладкам.

ПриВыбореЗакладки
Предопределенная процедура смены закладки формы.

Синтаксис:

ПриВыбореЗакладки(<НомерЗакладки>, <Значение3акладки>)

Англоязычный синоним:

OnTabCtrlPosChanged

Параметры:
<НомерЗакладки> Числовое значение — номер выбранной закладки формы.
<Значение3акладки> Значение выбранной закладки формы.

Описание:
Вызов предопределенной процедуры ПриВыбореЗакладки производится в системе 1С:Предприятие неявно в момент интерактивного выбора пользователем закладки в форме. При вызове процедуры, система подставляет фактические значения параметров, характеризующие выбранную закладку.
Параметры <НомерЗакладки> и <Значение3акладки> используется в теле процедуры для обработки передаваемого системой события смены закладки формы.

Ну, наконец-то. Давайте быстрее все сделаем.

Процедура ПриОткрытии()
	Форма.ИспользоватьЗакладки(1);   
	Форма.Закладки.ДобавитьЗначение(1, "Основной");
	Форма.Закладки.ДобавитьЗначение(2, "Слой1"); 
	Форма.ИспользоватьСлой("Основной");
КонецПроцедуры
        
Процедура ПриВыбореЗакладки(НомерЗакладки, ЗначениеЗакладки)  
 	
	Если НомерЗакладки=1 Тогда
		Форма.ИспользоватьСлой("Основной");
	Иначе
		Форма.ИспользоватьСлой("Слой1");
	КонецЕсли;  

КонецПроцедуры	

Запускаем:

81_1.gif (7857 b)

Вот оно. Разные слои разные закладки.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.