Шаг 73 - А теперь получим проводки

Добавим код для получения проводок. Там все нам известно. Вот код:

Процедура Сформировать() 

	Т = СоздатьОбъект("Таблица");
	Т.ИсходнаяТаблица("Таблица");  

	Док = СоздатьОбъект("Документ");
	Док.ВыбратьДокументы(ДатаНач, ДатаКон);

	Пока Док.ПолучитьДокумент() > 0 Цикл
		Т.ВывестиСекцию("Секция_1");
		Т.ВывестиСекцию("Секция_2"); 
		Док.Операция.ВыбратьПроводки();
          	        
		Пока Док.Операция.ПолучитьПроводку() = 1 Цикл
			Т.ВывестиСекцию("Секция_3"); 
		КонецЦикла;
	КонецЦикла;

	Т.ТолькоПросмотр(1);
	Т.Показать();

КонецПроцедуры

Сама секция:

73_1.gif (4639 b)

Смотрим результат:

73_2.gif (2762 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.