Шаг 66 - Изучаем операции – ПолучитьПроводку

Выбрав проводки из соответствующей операции, мы можем эти проводки получать. Одну за другой. Для этого есть функция.

ПолучитьПроводку
Получить проводку из выборки, открытой методом
ВыбратьПроводки.

Синтаксис:

ПолучитьПроводку()

Англоязычный синоним:

GetEntry

Возвращаемое значение:
Число: 1 — следующая проводка выбрана успешно; 0 — следующая проводка не выбрана (отсутствует).

Описание:
Метод ПолучитьПроводку выбирает очередную проводку из выборки, содержащей проводки текущей операции. Перед применением метода ПолучитьПроводку выборка должна быть открыта при помощи метода ВыбратьПроводки.
Метод ПолучитьПроводку используется для организации цикла по проводкам текущей операции. Условием цикла может служить равенство 1 возвращаемого значения метода: цикл выполняется, пока метод ПолучитьПроводку возвращает 1.
Метод возвращает 0, когда очередная проводка не выбрана. Это происходит, если при предыдущем применении метода была выбрана последняя проводка выборки.

Вот и будем выбирать проводки.

Процедура Сформировать() 
	...

	Пока Опер.ПолучитьОперацию() = 1 Цикл
		Т.ВывестиСекцию("Секция_1"); 
		Опер.ВыбратьПроводки();
			Пока Опер.ПолучитьПроводку() = 1 Цикл
				Т.ВывестиСекцию("Секция_2"); 
			КонецЦикла;
	КонецЦикла;

	...

КонецПроцедуры

В секции 2 мы будем просто выводить слово "Проводка" пока.

66_1.gif (3751 b)

Запустим, посмотрим:

66_2.gif (2020 b)

Пока мы видим, что в каждой операции всего одна проводка.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.