Шаг 57 - Изучаем Счета – Выводим виды субконто - ВидСубконто

Получив количество мы можем получить и вид прикрепленного субконто. Для этого есть функция.

ВидСубконто
Устанавливает/возвращает вид субконто счета.

Синтаксис:

ВидСубконто(<НомерСубконто>, <ВидСубконто>, <ТолькоОбороты>)

Англоязычный синоним:

SubcontoKind

Параметры:
<НомерСубконто> Числовое выражение — порядковый номер субконто счета.
<ВидСубконто> Необязательный параметр. Значение типа «Вид субконто», которое должно быть установлено.
<ТолькоОбороты> Необязательный параметр. Числовое значение: 1 или 0. Данный параметр снимает или устанавливает флаг «Только обороты» для данного субконто счета. Если параметр не используется, то флаг «Только обороты» не меняется.

Возвращаемое значение:
Значение типа «Вид субконто».

Описание:
К любому счету или субсчету в плане счетов может быть «прикреплено» до 5 видов субконто. Максимальное количество видов субконто, которое можно «прикрепить» к счету, устанавливается в конфигураторе при редактировании свойств планов счетов. Количество субконто, которое реально прикреплено к счету, не превышает установленного максимального количества. Все виды субконто, прикрепленные к счету в плане счетов, имеют порядковые номера. Эти номера выдаются в названии колонок для видов субконто в окне редактирования плана счетов; «Субконто!», «Субконто2» ... «Субконто5».
Метод ВидСубконто при использовании его без второго параметра возвращает значение типа «ВидСубконто», имеющего порядковый номер, переданный в качестве первого параметра.
Метод ВидСубконто при вызове со вторым параметром устанавливает у счета вид субконто, имеющего порядковый номер, переданный в качестве первого параметра.
Применение данного метода следует производить только в особых случаях и с учетом всех особенностей настройки учета. После изменения настроек учета система может потребовать выполнить пересчет итогов.

Мы сейчас ее применим для того, что бы вывести в информации о счете еще и вид субконто. Для начала создадим переменную в которой будет вид.

Процедура Сформировать()  
Перем  ИнформацияКол;
Перем  ИнформацияСубсч; 
Перем  ВидСубконтоСчета;
.........
КонецПроцедуры

Теперь пробежимся по видам субконто.

Процедура Сформировать()

	.........
	Т.ВывестиСекцию("Секция_2"); 
	Т.ВывестиСекцию("Секция_3");
	Т.ВывестиСекцию("Секция_4");
   
	Для Инд = 1 По ВыборСчета.КоличествоСубконто() Цикл
		ВидСубконтоСчета= ВыборСчета.ВидСубконто(Инд);
		Т.ВывестиСекцию("Секция_5");
	КонецЦикла;
        
	Т.ТолькоПросмотр(1);
	Т.Показать();
КонецПроцедуры

Отлично выведем в секции вид субконто.

57_1.gif (4681 b)

Смотрим результат.

57_2.gif (2413 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.