Шаг 54 - Зачем нужны субконто

Рекомендую прочитать:

Субконто нужен для аналитического учета. Мы с Вами уже делали проводки с одного счета на другой. В конечном итоге на счете скапливается сумма. А вот аналитический учет позволит проанализировать эту сумму по субконто. Можете рассматривать субконто как атрибутивную информацию (дополнительную) к денежным суммам. Количество субконто является глобальным свойством плана счетов. Для того, чтобы добраться до установки количества субконто нужно выбрать контекстное меню плана счетов.

54_1.gif (4245 b)

И среди прочих установок будет количество субконто.

54_2.gif (9511 b)

Итак, субконто позволяет добавить дополнительную информацию к денежной сумму. При проведении денежных сумм можно в проводке указывать субконто.

54_3.gif (4847 b)

А в последствии, например, выявлять все скажем операции которые проводились с этим субконто. Забегая вперед вот код для примера.

Процедура Сформировать() 

	Если ВыбранныйСубконто.Выбран() = 0 Тогда
		Предупреждение("Не указан вид субконто!");
		Возврат;
	КонецЕсли; 
	
	Если ВыбранныйСчет.Выбран() = 0 Тогда
		Предупреждение("Не указан Счет!");
		Возврат;
	КонецЕсли;
	
    Т = СоздатьОбъект("Таблица");
    Т.ИсходнаяТаблица("Таблица");     
    
    
    Опер = СоздатьОбъект("Операция");
    Опер.ВыбратьОперации(ДатаНач, ДатаКон);
    
    Пока Опер.ПолучитьОперацию()=1 Цикл
    	  
		Опер.ВыбратьПроводки();
    	   
		Пока Опер.ПолучитьПроводку() = 1 Цикл  
    	  	 
			Если ВыбранныйСчет=Опер.Дебет.Счет Тогда  
    	  	 	
				Если Опер.Дебет.Субконто()=ВыбранныйСубконто Тогда
					Т.ВывестиСекцию("Секция_1");             
				КонецЕсли;
    	  	   	
			КонецЕсли
    	  	 
		КонецЦикла;

	КонецЦикла;
    
	Т.ТолькоПросмотр(1);
	Т.Показать();
   
КонецПроцедуры

Этот код отбирает все проводки по субконто.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.