Шаг 405 - Абсолютно универсальный документ

Используя полученные навыки в прошлых шагах можно сделать универсальный документ на все случаи жизни. Достаточно в документе сделать две переменные с типом счет.

405_1.gif (8973 b)

Потом при выборе счета назначить тип субконто и сделать поле сумма.

405_2.gif (3187 b)

Вот и все. В форме определение субконто.

Процедура ПриВыбореСчетаДебета()
	НазначитьТип("СубД1", СчетДебета.ВидСубконто(1));
	НазначитьТип("СубД2", СчетДебета.ВидСубконто(2));
	НазначитьТип("СубД3", СчетДебета.ВидСубконто(3));
КонецПроцедуры


Процедура ПриВыбореСчетаКредита()
	НазначитьТип("СубК1", СчетКредита.ВидСубконто(1));
	НазначитьТип("СубК2", СчетКредита.ВидСубконто(2));
	НазначитьТип("СубК3", СчетКредита.ВидСубконто(3));
КонецПроцедуры

В проведение указание субконто.

Процедура ОбработкаПроведения()

	ВыбратьСтроки();
	Пока  ПолучитьСтроку()=1  Цикл
		Операция.НоваяПроводка();
		Операция.Дебет.Счет = СчетДебета;  
		Операция.Дебет.Субконто(1,СубД1);
		Операция.Дебет.Субконто(2,СубД2);
		Операция.Дебет.Субконто(3,СубД3);
		Операция.Кредит.Счет = СчетКредита; 
		Операция.Кредит.Субконто(1,СубК1);
		Операция.Кредит.Субконто(2,СубК2);
		Операция.Кредит.Субконто(3,СубК3); 
		Операция.Сумма=Сумма;
	КонецЦикла;
	Операция.Записать();
КонецПроцедуры

Вот и все, да чуть не забыл. Счет может быть количественный. Тогда нужно сделаь колонку количество. Как определить, что счет количественный ? Читаем - "Шаг 41 - Изучаем Счета – Количественный". А еще может быть валютный. Про это пока не писал.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.