Шаг 389 - Отбор по нескольким субконто – дальше

В типовой конфигурации для многих счетов используется несколько субконто. Например, для 10 счетов это материалы и места хранения.

389_1.gif (4015 b)

Наша задача сделать простой отчет, который будет показывать наличие материалов по местам хранения. Делаем отчет и помещаем на форму дату, счет, место хранения.

389_2.gif (2882 b)

Отбор основан на простом факте, который есть в описании ИспользоватьСубконто. Там написано, что данную функцию можно вызывать несколько раз подрят. Вот так будет выглядеть наш отчет.

//*******************************************
Процедура Сформировать()    
	Т = СоздатьОбъект("Таблица");
	Т.ИсходнаяТаблица("Таблица");
	Т.ВывестиСекцию("Секция_1");
	Итог = СоздатьОбъект("БухгалтерскиеИтоги");
	Итог.ИспользоватьСубконто(ВидыСубконто.Материалы, , 1);
	Итог.ИспользоватьСубконто(ВидыСубконто.МестаХранения, , 1);
	Итог.ВыполнитьЗапрос(ДатаНач,ДатаНач,ВыбранныйСчет); 
	Итог.ВыбратьСубконто(1);
	Пока Итог.ПолучитьСубконто(1) = 1 цикл 
		Если  МестоХранения.Выбран()=1 Тогда                      
			Если Итог.Субконто(2)= МестоХранения Тогда
				Т.ВывестиСекцию("Секция_2");
			КонецЕсли;     
		Иначе
			Т.ВывестиСекцию("Секция_2");
		КонецЕсли;
	КонецЦикла;      
	Т.ТолькоПросмотр(1);
	Т.Показать() 
КонецПроцедуры

Мы два раза вызывали ИспользоватьСубконто а дальше при ВыбратьСубконто, ПолучитьСубконто, Субконто указываем его номер. Все просто.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.