Шаг 381 - Создаем функцию перевода месяца на английский

Итак, как извлечь номер месяца мы знаем, но нам нужно его перевести на английский. Вот так это выглядит:

1		январь		January
2		февраль		February
3		март		March
4		апрель		April
5		май		May
6		июнь		June
7		июль		July
8		август		August
9		сентябрь		September
10		октябрь		October
11		ноябрь		November
12 		декабрь		December

Вот и создадим глобальную функцию.

Функция ДатаПоАнглийски(ДатаПеревода) export
	ЗначениеМесяца = ДатаМесяц(ДатаПеревода);
	Если ЗначениеМесяца=1  Тогда Возврат "January"  КонецЕсли;    
	Если ЗначениеМесяца=2  Тогда Возврат "February" КонецЕсли;
	Если ЗначениеМесяца=3  Тогда Возврат "March" КонецЕсли;
	Если ЗначениеМесяца=4  Тогда Возврат "April"  КонецЕсли;
	Если ЗначениеМесяца=5  Тогда Возврат "May"   КонецЕсли;
	Если ЗначениеМесяца=6  Тогда Возврат "June"  КонецЕсли;
	Если ЗначениеМесяца=7  Тогда Возврат "July"   КонецЕсли;
	Если ЗначениеМесяца=8  Тогда Возврат "August"  КонецЕсли;
	Если ЗначениеМесяца=9  Тогда Возврат "September" КонецЕсли;
	Если ЗначениеМесяца=10  Тогда Возврат "October"  КонецЕсли;
	Если ЗначениеМесяца=11  Тогда Возврат "November" КонецЕсли;
	Если ЗначениеМесяца=12  Тогда Возврат "December" КонецЕсли;
КонецФункции

А теперь вызовем ее.

//*******************************************
Процедура Сформировать()         
	Перем пр;
	пр= ДатаПоАнглийски(РабочаяДата());
	Т = СоздатьОбъект("Таблица");
	Т.ВывестиСекцию("Секция_1");
	Т.ТолькоПросмотр(1);
	Т.Показать();
КонецПроцедуры

И смотрим результат.

381_1.gif (2689 b)

Все правильно, сейчас декабрь (вы можете читать эти шаги в другое время кстати :).


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.