Шаг 360 - Осталось определить количество строк

После группировке для того, чтобы пробежаться по всем значениям нам нужно определить количество строк. Такая функция есть.

КоличествоСтрок
Устанавливает/возвращает количество строк в таблице значений,

Синтаксис:

КоличествоСтрок(<НовоеКоличествоСтрок>)

Англоязычный синоним:

LinesCnt

Параметры:
<НовоеКоличествоСтрок> - Необязательный параметр. Новое количество строк в таблице значений.

Возвращаемое значение:
Числовое значение — количество строк в таблице значений до вызова метода.

Описание:
Метод Количество Строк устанавливает/возвращает количество строк в таблице значений.

Имея строки мы может пробежаться по результатам группировки. Вот полный код:

//*******************************************
Процедура Сформировать()         
	Перем х;
	Перем стр;
	Перем сумма;

	Результат = СоздатьОбъект("ТаблицаЗначений"); 

	Результат.НоваяКолонка("ГруппыОС","Перечисление.ГруппыОС");
	Результат.НоваяКолонка("начБаланс");
       
       
	Т = СоздатьОбъект("Таблица");
	БИ = СоздатьОбъект("БухгалтерскиеИтоги");
	БИ.ИспользоватьСубконто(ВидыСубконто.ОсновныеСредства);
	БИ.ВыполнитьЗапрос(ДатаНач,ДатаКон,"01.1");
	БИ.ВыбратьСубконто(1,0,0,0,0,"Группа",0);
	Пока БИ.ПолучитьСубконто() = 1 Цикл
		Результат.НоваяСтрока();
		Результат.ГруппыОС = БИ.Субконто().Группа;
		Результат.начБаланс=БИ.СНД();
	КонецЦикла;
                                       
	Результат.Свернуть("1","2");
	у = Результат.КоличествоСтрок();
	Для x=1 По у Цикл
		стр=Результат.ПолучитьЗначение(x,1);
		сумма=Результат.ПолучитьЗначение(x,2);
		Т.ВывестиСекцию("Секция_1");
	КонецЦикла;
 
	Т.ТолькоПросмотр(1);
	Т.Показать();
КонецПроцедуры

Таблица.

360_1.gif (1191 b)

Результат.

360_2.gif (2891 b)

Таким способом можно формировать отчетность по любому атрибуту справочника на основе которого создается субконто (Для тех кто подзабыл "Шаг 21 - Виды субконто").


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.