Шаг 349 - Устанавливаем вид реквизита по счету

Теперь пора объединить все наши знания. Вот код установки реквизитов:

Процедура ПриВыбореСчета() 
Перем х;
х=ВыбранныйСчет.КоличествоСубконто();  
Если х>0 тогда 
	Форма.Субконто1.НазначитьТип(ВыбранныйСчет.ВидСубконто(1));
КонецЕсли;	
Если х>1 тогда 
	Форма.Субконто2.НазначитьТип(ВыбранныйСчет.ВидСубконто(2));
КонецЕсли;	
Если х>2 тогда 
	Форма.Субконто3.НазначитьТип(ВыбранныйСчет.ВидСубконто(3));	
КонецЕсли;	

КонецПроцедуры

При работе следует обратить внимание, что виды субконто устаналиваются именно для одной строки, а не для всей таблицы. Это легко проверить. Введите несколько строк.

349_1.gif (7269 b)

Потом выберите счет.

349_2.gif (3952 b)

И теперь в данной строке Вы сможете выбрать субконто сотвествующее данному счету.

349_3.gif (2877 b)

Но только для данной строки. Это не плохо, для ряда задач даже очень хорошо. Если нужно установить для всех строк, то по ним можно и пробежаться.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.