Шаг 335 - Как работать с метаданными

предусматривает объект Метаданные. Это глобальный объект и его нет необходимости создавать. Давайте посмотрим как с этим объектом можно работать. Простой отчет и кнопка сформировать. Допустим получим список справочников

Процедура Сформировать()
	Для Инд = 1 По Метаданные.Справочник() Цикл
		Сообщить(Метаданные.Справочник(Инд));
	КонецЦикла;
КонецПроцедуры

Вот результат:

335_1.gif (1485 b)

Или документы:

Процедура Сформировать()
	Для Инд = 1 По Метаданные.Документ() Цикл
		Сообщить(Метаданные.Документ(Инд));
	КонецЦикла;
КонецПроцедуры

Вот документы:

335_2.gif (1334 b)

Идея заключается в том, что после объекта метаданных указывается непосредственный объект метаданных и организуется цикл.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.