Шаг 321 - Как проводится ввод в эксплуатацию, дальше

Дальше идет стандартная проверка на ошибки.

Если БалансоваяСтоимость = 0 Тогда
	Сообщение = "Не указана первоначальная стоимость основного средства.";
	глОшибкаПроведения(Контекст, Сообщение);
	СтатусВозврата(0); Возврат;
ИначеЕсли ПустоеЗначение(ОбъектВнеоборотныхАктивов) = 1 Тогда
	Сообщение = "Не указан объект внеоборотных активов.";
	глОшибкаПроведения(Контекст, Сообщение);
	СтатусВозврата(0); Возврат;
ИначеЕсли КоличествоСтрок() = 0 Тогда
	Сообщение = "Не указаны основные средства, вводимые в эксплуатацию.";
	глОшибкаПроведения(Контекст, Сообщение);
	СтатусВозврата(0); Возврат;
КонецЕсли;

Должна быть указана первоначальная стоимость, объект необоротных активов и само основное средство. В случае ошибки вызывается функция из глобального модуля глОшибкаПроведения:

Процедура глОшибкаПроведения(Конт, Сообщение, НомСтроки=0) Экспорт
	Перем Стр;

	Стр = "";
	Если НомСтроки <> 0 Тогда
		Стр = ", строка № " + НомСтроки;
	ИначеЕсли Конт.НомерСтроки  <> 0 Тогда
		Стр = ", строка № " + Конт.НомерСтроки;
	КонецЕсли;

	НеКомментировать = ВосстановитьЗначение("НеКомментироватьПроведениеДокументов");
	Если НеКомментировать = 1 Тогда
		Сообщить("________________________________________________________________________________");
		Сообщить("Документ "+Конт.ТекущийДокумент()+": проведение документа ("+РабочаяДата()+"/"+ТекущееВремя()+")", "I");
	КонецЕсли;

	Сообщить(Сообщение, "!");
	Сообщить("Документ "+Конт.ТекущийДокумент()+ " не будет проведен.","!");
КонецПроцедуры //глОшибкаПроведения

Как видите эта функция просто формирует строку вывода.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.