Шаг 311 - Что происходит при открытии ВводВЭксплуатациюОС – Дальше

Смотрим дальше:

Процедура ПриОткрытии()
	ПриЗаписиПерепроводить(1);
	глПроверкаРазрешенияРедактирования(Контекст);
	....

Дальше вызывается функция глобального модуля. Вот она:

Процедура глПроверкаРазрешенияРедактирования(Конт) Экспорт
	Если Конт.Выбран() = 1 Тогда
		Если (Конт.ДатаДок <= Константа.ДатаЗапретаРедактирования) и (Конт.Форма.ТолькоПросмотр() = 0) Тогда
			Конт.Форма.ТолькоПросмотр(1);
			Предупреждение("Разрешен только просмотр документа!", 4);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

Здесь идет проверка на разрешение редактирования документа. Для учета по какой дате документ можно редактировать в типовой конфигурации заведена константа ДатаЗапретаРедактирования:

311_1.gif (2114 b)

Если дата документа меньше этой константы, то редактировать документ нельзя. Только смотреть.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.