Шаг 306 - Что в конце процедуры печати ОС-6

Дальше получаются все необходимые дополнительные сведения:

......
	Если ТекущийЭлемент().ШифрПоЕНАОФ.Выбран() = 1 Тогда
		КодНормы = ТекущийЭлемент().ШифрПоЕНАОФ.Код;
	Иначе
		КодНормы = "";
	КонецЕсли;

	Если ТекущийЭлемент().СчетЗатрат.Получить(РабочаяДата()).Выбран() = 1 Тогда
		КодСчетаЗатрат = ТекущийЭлемент().СчетЗатрат.Получить(РабочаяДата()).Код;
	Иначе
		КодСчетаЗатрат = "";
	КонецЕсли;
     
	Таб.Вывести();
	Таб.ТолькоПросмотр(1);
	Таб.ПараметрыСтраницы(2,,,,,,,,,,,);
	Таб.Опции(0,0,0,0,"ОпцииПечатиОС6","ОкноОС6");
	Таб.Показать("Инвентарная карточка");
КонецЕсли;
КонецПроцедуры  //Печать
......

И запускается таблица, а все полученные переменные используются в соответствующих полях.

306_1.gif (8592 b)


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.