Шаг 241 - Передача параметров в форму – способ первый

Самый простой способ использовать глобальные переменные в глобальном модуле. Подробнее:

Заведем в глобальном модуле переменную ДатаНачалаГлобально:

........
Перем ДатаНачалаГлобально Экспорт;
........

А в конце глобального модуля ее инициализируем:

........
ДатаНачалаГлобально="";
........

Теперь перед запуском отчета ее устанавливаем:

Процедура НажалиКнопку()
	ДатаНачалаГлобально="01.01.2002";
	ОткрытьФорму("Отчет.КнигаПродаж");
КонецПроцедуры

А в момент открытия отчета проверяем установлена она или нет. Если установлена, то присваиваем значение нужному элементу и сбрасываем ее, чтобы в следующий раз, если запустят универсальный отчет, она не болталась.

Процедура ПриОткрытии()  
	Если  ДатаНачалаГлобально<>"" Тогда
		ДатаНач= ДатаНачалаГлобально;
		ДатаНачалаГлобально="";
	КонецЕсли;
КонецПроцедуры

Посмотрим.

241_1.gif (3431 b)

Отлично сработало.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.