Шаг 208 - Так что же делать с переключателем

Раз мы поняли, что переключатель нам создать не удается и надо будет его состояние хранить в переменной, то тут нужно, во-первых, при создании документа устанавливать его по умолчанию.

Процедура ВводНового() 
	......
	ТипРасчета=1;
	ВыборРасчета=ТипРасчета;	
КонецПроцедуры

При открытии читать его из переменной и устанавливать состояние.

Процедура ПриОткрытии()
	ВыборРасчета=ТипРасчета;	
	......
КонецПроцедуры

При изменении тут же менять переменную.

Процедура ПриВыборе()  
	ТипРасчета=ВыборРасчета;
	Если ТипРасчета=1 Тогда
		......
	Иначе 
		......
	КонецЕсли
КонецПроцедуры

Остается еще ввод на основании. То есть вызовется ли ВводНового при ВводНаОсновании. Нет не вызовется. Но никто Вам не мешает сделать так.

Процедура ВводНового()
	Предупреждение(ДатаДок);
КонецПроцедуры      

Процедура ВводНаОсновании(ДокОсн)  
	ВводНового(); 
КонецПроцедуры

А вот, если Вы внутри ВводНового сделали запрет на введение документа без основания, как в шаге "Шаг 161 - Изучаем документ – Запрещаем создавать новый", то нужно описать инициализацию переменной и флага в ВводНаОсновании.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.