Шаг 198 - Процедуры и функции обратного хода

Первое, что мы сделаем - это функцию в глобальном модуле, которая будет вычислять из процента коэффициент.

Функция ПроцентКоэффициент(Процент) export
	ПроцентКоэффициент=1+(Процент/100);
	Возврат ПроцентКоэффициент;
КонецФункции

Функциями мы не пользовались, так что смотрите. Теперь создадим нашу процедуру.

Процедура ОбратныйХод(СуммаИтоговая,ПроцентНПродаж,ПроцентНДС,СуммаНалогаСПР,СуммаНДС,СуммаНачальная) export
	СуммаБезНалогаСПродаж =  СуммаИтоговая/ПроцентКоэффициент(ПроцентНПродаж);
	СуммаНачальная=СуммаБезНалогаСПродаж/ПроцентКоэффициент(ПроцентНДС);
	СуммаНалогаСПР=СуммаИтоговая-СуммаБезНалогаСПродаж;
	СуммаНДС=СуммаБезНалогаСПродаж-СуммаНачальная;
КонецПроцедуры

Опробуем ?

198_1.gif (9001 b)

А теперь при вводе итоговой суммы делаем расчет.

Процедура Считать()  
	ОбратныйХод(СуммаИтоговая,НалогСПродаж,НДС,СуммаНалогаСПродаж,НДССумма,СуммаОбщая);
КонецПроцедуры

Смотрим результат.

198_2.gif (8048 b)

Вроде как получилось.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.