Шаг 171 - Пример оперативного учета с использованием документов

Вопрос стал этот вот по какой причине. Предприятие оказывает посреднические услуги по доставке топлива. Нет, оно занимается огромным количеством дел, но в том числе и посредническими услугами по доставке топлива. При этом за доставку топлива оно ничего не берет. Просто перекладывает расходы копейка в копейку на заказчика. Смысл в этом есть. Данная организация конечно не в убытке. Она делает торговую наценку по определенному виду деятельности и все. Все остальное просто транзит через нее. Зачем. Понятно за чем. Она выступает в роли заказчика топлива с большими оборотами. Получает за это скидку. За объем. А так как топливо идет через него транзитом без наценок, то конкретному клиенту этого предприятия получается дешевле. Но и не только стоимость топлива, но и стоимость перевозки. И таких видов прямого транзита много. Зато за услуги по доставки материалов она берет 3% как наценку. Так вот, если посчитать общий баланс, то получается, что работать с ним клиенту в общей сумме выгоднее. Количество скидок превышает эти 3% при работе по многим позициям и голова не болит. Заказал что нужно и получил. Ни тебе командировок, ни тебе договоров и всякой там мути. Я немного отвлекся, просто модель красивая. Так вот за перевозку топлива выставляются ТТН. То есть товарно-транспортные накладные. Эти накладные в течении месяца приходят на предприятия с указанием большого количества параметров.

171_1.gif (8914 b)

Обратите внимание, что есть перевозчик, он может быть разный. Есть получатель, он тоже может быть разным. А еще номера ТТН, вес, расстояние, тариф и так далее. В конце месяца множество этих ТТН суммируется и выставляется счет. Так вот этот счет в бух учете составляет всего несколько проводок. Но к этому счету нужны расшифровки. Чтобы доказать когда и сколько перевезли и сколько в сумме это стоило. Да и НДС нужно выделить. В течении месяца может потребоваться информация в разных разрезах. Вот это все оперативный учет. Решить задачу получения информации в течении какого-то периода можно извлечением и анализом документов. Примерно вот так.

....
Пока Док.ПолучитьДокумент() < 0  Цикл   
	Если Перевозчик.Выбран()=1 Тогда
		Если Перевозчик =  Док.Поставщик Тогда 
			Если Получатель.Выбран()=1 Тогда
				Если Получатель=Док.АдресПеревозки Тогда
					ПечатьТТН();
				КонецЕсли;
			Иначе	
				ПечатьТТН();	
			КонецЕсли; 	
		КонецЕсли;
	Иначе  
		Если Получатель.Выбран()=1 Тогда
			Если Получатель=Док.АдресПеревозки Тогда
				ПечатьТТН();
			КонецЕсли;	
		Иначе	
			ПечатьТТН();			
		КонецЕсли;
	КонецЕсли;	 
КонецЦикла;
....

И отчет построить.

171_2.gif (4350 b)

В разных разрезах. Я сделал так. Но анализ книги покупок в перспективе дело долгое из-за большого количества документов. Нужно попробовать все это организовать с использованием регистров. Попробуем ?


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.