Шаг 165 - Изучаем документ – Готовимся к контролю

Мне нужно запретить использовать основание более одного раза. Как быть в этой ситуации. Способов много, попробую предложить свой. Нам в шапке документа нужно завести флаг использования. Заведем.

165_1.gif (6982 b)

При создании нового документа будем его устанавливать в ноль.

Процедура ВводНового() 
	ВыпискаОснования=0;
КонецПроцедуры

Теперь нам нужно в документе, который будет создан на основании этого документа проверит этот флаг.

Процедура ВводНаОсновании(ДокОсн)
	Если ДокОсн.Вид() = "Док1" Тогда
		Если ДокОсн.ВыпискаОснования = 0 Тогда
			ДатаДок=ДокОсн.ДатаДок;
		Иначе
			Предупреждение("Вы этот документ уже использовали ");
			СтатусВозврата(0);
		КонецЕсли;
	Иначе
		Предупреждение("Вы пытаетесь использовать неправильное основание "); 
		СтатусВозврата(0);	
	КонецЕсли;
КонецПроцедуры

Отлично. Но пока мы просто проверяем, а этот флаг нужно еще и устаналивать.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.