Шаг 123 - Изучаем справочник – как проверить что выбран

В любом варианте программно или на форме, пользователь обязательно забудет выбрать элемент справочника. Вот забудет и все. Поэтому нам нужно это проверять. Такая возможность есть.

Выбран
Проверить факт выбора элемента справочника.

Синтаксис:

Выбран()

Англоязычный синоним:

Selected

Возвращаемое значение:
Числовое значение: 1 — если элемент справочника выбран (спозиционирован); 0 — если не выбран.

Описание:
Метод Выбран возвращает число со значением 1 — если элемент справочника выбран (спозиционирован), 0 — если элемент справочника не выбран.

Попробуем в нашем коде.

Процедура Сформировать()    

	Спр = СоздатьОбъект("Справочник.Контрагенты");
	Спр.НайтиПоНаименованию("Авто - Карьер", 1); 
	Если Спр.Выбран() > 0 Тогда  
		Предупреждение(Спр.Код);
	Иначе     
		Спр.Выбрать("Авто - Карьер","");   
		Если Спр.Выбран() = 0 Тогда
			Предупреждение("Ну че ты в конце концов.");
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

Пользователь может отказаться от выбора справочника нажав ESC. Тогда он получит вот такое сообщение.

123_1.gif (3465 b)

Ну, а дальше Вы сами решите, что делать. По мне вырубить комп самое то, если не понимают люди, что просто нужно выбрать.


Предыдущий Шаг | Следующий Шаг | Оглавление
Автор Каев Артем.